summaryrefslogtreecommitdiff
path: root/dev-libs/libcxml/libcxml-5.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcxml/libcxml-5.2.0.ebuild')
-rw-r--r--dev-libs/libcxml/libcxml-5.2.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libcxml/libcxml-5.2.0.ebuild b/dev-libs/libcxml/libcxml-5.2.0.ebuild
new file mode 100644
index 0000000..dd62a4e
--- /dev/null
+++ b/dev-libs/libcxml/libcxml-5.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcxml/libcxml-5.2.0.ebuild,v 1.9 2005/08/24 09:06:34 taviso Exp $
+
+inherit eutils rpm
+
+DESCRIPTION="Compaqs eXtended Math Library for linux alpha"
+HOMEPAGE="ftp://ftp.compaq.com/pub/products/C-CXX/linux/"
+SRC_URI="ev6? (cxml_ev6-5.2.0-2.alpha.rpm)
+ !ev6? (cxml_ev5-5.2.0-2.alpha.rpm)"
+
+LICENSE="compaq-sdla"
+SLOT="0"
+KEYWORDS="-* ~alpha"
+IUSE="ev6 doc"
+RESTRICT="fetch strip"
+
+S="${WORKDIR}/usr"
+
+DEPEND="virtual/libc
+ app-arch/rpm2targz
+ dev-libs/libots
+ dev-libs/libcpml"
+RDEPEND="dev-libs/libots
+ dev-libs/libcpml"
+
+# non portage variable
+RELEASE="5.2.0-2"
+
+src_unpack() {
+ local EV; use ev6 && EV=ev6 || EV=ev5
+
+ rpm_src_unpack
+
+ if ! use doc >/dev/null ; then
+ einfo "Removing unwanted documentation (USE=\"-doc\")..."
+ rm -rf usr/doc
+ else
+ einfo "Reorganising Documentation..."
+ mkdir usr/share
+ mv usr/doc usr/share/
+ fi
+
+}
+
+src_compile () {
+ local EV; use ev6 && EV=ev6 || EV=ev5
+ cd ${WORKDIR}/usr/lib/compaq/cxml-${RELEASE%*-2}
+
+ ld -shared -o libcxml_${EV}.so -soname libcxml.so \
+ -whole-archive libcxml_${EV}.a -no-whole-archive -lots -lcpml
+}
+
+src_install () {
+ mv ${WORKDIR}/usr "${D}"
+ prepalldocs
+}